Bootstrap 3.3.0发布 版本4不再支持IE8

发布时间:2014/10/30 标签: Bootstrap 分类:前端框架

Bootstrap 3.3.0正式发布,该版本主要集中于Bug修复、提高可访问性以及更新文档。我们收到了来自28位贡献者的700多次提交。

Bootstrap官网:http://getbootstrap.com/

其中值得关注的特性有:

  • 添加少量的Less变量,以便于进行定制;
  • 删除了进度条在低百分比时的变化;
  • 移除了所有的translate3d实例,原因是它们会提高重绘性能,并且还会增加一些跨浏览器Bug;
  • 添加变换来提升转盘在现代浏览器下的性能;
  • 更新Normalize.css和H5BP打印样式到最新版本;
  • 提升导航、面板、工具提示、按钮等控件的可访问性;
  • 解决了很多JavaScript和文档Bug。

关于该版本的更多详细信息,大家可以阅读变更日志v3.3.0 milestone

于此同时,我们还发布了两个新工具:

  • Bootlint:为Bootstrap项目提供可定制的linter;
  • Rorschach:用来检查新的Pull Requests以找出一些常见错误。

即将面世的Bootstrap 4:

几周后,Bootstrap 4的首个allpha版本就会与大家见面,先让大家看看有哪些新特性及改进吧:

  • 更新网格系统,更好地支持移动设备;
  • 一个新的组件面世,用来代替面板、缩略图和wells;
  • 一个全新的、更简单的导航栏;
  • 把所有的像素值转换成rems和ems,以便于更好地支持类型和组件尺寸;
  • 不再支持IE8;
  • 大量的表单更新,包括自定义表单控件;
  • 新的组件动画和转换;
  • UMD支持所有的JavaScript插件;
  • 改进JavaScript定位工具提示、popovers和下拉菜单;
  • 采用Markdown编写的全新文档;
  • 提供一个新方法来配置全局主题选项;
  • 还有数以百计的更新及变化。

关于更多新特性及更新,大家还期待数月后发布的v4版本吧。关于v3版本,我们会继续维护,主要是bug修复。

现代浏览器推荐

做为一名前端人员,您有责任且有义务让用户升级浏览器拥有完美的浏览体验,与国际接轨,同时让更多的前端人员不再苦逼! 本站将不再支持IE9以下的版本!

QQ交流群

学习使人进步,交流让人提高!

Bootstrap/HTML5/CSS3交流群:233808496

Orchard/Nopcommerce/Umbraco交流群:187502451

Bootstrap/HTML5/CSS3交流二群:385480040